Skip to main content

Fibonacci-dp

 1. You are given a number n.

2. You are required to print the nth element of fibonnaci sequence.


Note -> Notice precisely how we have defined the fibonnaci sequence

0th element -> 0

1st element -> 1

2nd element -> 1

3rd element -> 2

4th element -> 3

5th element -> 5

6th element -> 8

Input Format

A number n

Output Format

A number representing the nth element of fibonnaci sequence


Constraints

0 <= n <= 45

Sample Input

10

Sample Output

55


Solution:

import java.io.*;

import java.util.*;


public class Main{


public static void main(String[] args) throws Exception {

    // write your code here

    Scanner sc = new Scanner(System.in);

    int n = sc.nextInt();

    int[] A = new int[n+1];

    A[0] = 0;

    A[1] = 1;

    for(int i=2;i<=n;i++){

        A[i] = A[i-1] + A[i-2];

    }

    System.out.println(A[n]);

 }


}

Comments

Must Read:

Course DH ASE B3 Slot3 Mock 1 Handson | RDBMS

DH ASE B3          Slot3              Mock 1                  Handson: RDBMS

Software Engineering Concepts Software Engineering Fundamentals Post-Quiz

  Software Engineering Concepts       Software Engineering Fundamentals            Post-Quiz

Accenture Mock Quiz | Part 4

  Question  31 Correct Marked out of 1.00 Flag question Question text What will be the output of the following Java code? class Test extends Throwable { } class Base extends Test {} public class Main { public static void main(String args[]) { try { throw new Base(); } catch(Test t) { System.out.println("Test Exception"); } finally { System.out.println("Finally block "); } } } Select one: a.  Complilation error : Bass calss can't extends Test b.  print-"Test Exception" c.  Complilation error: Test Class cant extends Throwable d.  print - "Test Exception" "Finally block "   Feedback The correct answer is: print - "Test Exception" "Finally block " Question  32 Correct Marked out of 1.00 Flag question Question text Which of the following statement(s) is/are TRUE? (i) In a non-correlated(independent) subquery, the subquery is always executed only onc...

Subscribe to Get's Answer by Email