Skip to main content

Fibonacci-dp

 1. You are given a number n.

2. You are required to print the nth element of fibonnaci sequence.


Note -> Notice precisely how we have defined the fibonnaci sequence

0th element -> 0

1st element -> 1

2nd element -> 1

3rd element -> 2

4th element -> 3

5th element -> 5

6th element -> 8

Input Format

A number n

Output Format

A number representing the nth element of fibonnaci sequence


Constraints

0 <= n <= 45

Sample Input

10

Sample Output

55


Solution:

import java.io.*;

import java.util.*;


public class Main{


public static void main(String[] args) throws Exception {

    // write your code here

    Scanner sc = new Scanner(System.in);

    int n = sc.nextInt();

    int[] A = new int[n+1];

    A[0] = 0;

    A[1] = 1;

    for(int i=2;i<=n;i++){

        A[i] = A[i-1] + A[i-2];

    }

    System.out.println(A[n]);

 }


}

Comments

Must Read:

DFA Solutions

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text To secure the http messages in the API calls, its necessary to: Select one: a. All the above b. Use cryptography c. implement identity management d. avoid hardcoding any sensitive data in the messages Feedback The correct answer is: All the above Question  2 Correct Mark 1.00 out of 1.00 Remove flag Question text A team has completed 10 Sprints and moving to the 11th Sprint. Till Sprint 10, the team has achieved an average of 50 story points per sprint. The same is projected as their velocity for the upcoming sprints with the Client. What is this approach called? Select one: a. Velocity Driven Sprint Planning b. Velocity Driven Commitment c. Commitment Driven Velocity d. Commitment Driven Sprint Planning Feedback The correct answer is: Velocity Driven Sprint Planning Question  3 Incorrect Mark 0.00 out of 1.00 Remove flag Question text Jack is grooming himself to be a potential Product Owner. Kno...

Subscribe to Get's Answer by Email