Skip to main content

Arrange Buildings

1. You are given a number n, which represents the length of a road. The road has n plots on it's each side.

2. The road is to be so planned that there should not be consecutive buildings on either side of the road.

3. You are required to find and print the number of ways in which the buildings can be built on both side of roads.


Input Format

A number n

Output Format

A number representing the number of ways in which the buildings can be built on both side of roads.

Constraints

0 < n <= 45

Sample Input

6

Sample Output

441


Solution:

import java.io.*;

import java.util.*;


public class Main{


public static void main(String[] args) throws Exception {

    // write your code here

    Scanner scn = new Scanner(System.in);

    long n = scn.nextInt();


    long ob = 1;

    long os = 1;

    for (int i = 2; i <= n; i++) {

      long nb = os;

      long ns = os + ob;


      ob = nb;

      os = ns;

    }

    long total = ob + os;

    System.out.println(total * total);

 }


}

Comments

Must Read:

Course DH ASE B3 Slot3 Mock 1 Handson | RDBMS

DH ASE B3          Slot3              Mock 1                  Handson: RDBMS

Software Engineering Concepts Software Engineering Fundamentals Post-Quiz

  Software Engineering Concepts       Software Engineering Fundamentals            Post-Quiz

Accenture Mock Quiz | Part 4

  Question  31 Correct Marked out of 1.00 Flag question Question text What will be the output of the following Java code? class Test extends Throwable { } class Base extends Test {} public class Main { public static void main(String args[]) { try { throw new Base(); } catch(Test t) { System.out.println("Test Exception"); } finally { System.out.println("Finally block "); } } } Select one: a.  Complilation error : Bass calss can't extends Test b.  print-"Test Exception" c.  Complilation error: Test Class cant extends Throwable d.  print - "Test Exception" "Finally block "   Feedback The correct answer is: print - "Test Exception" "Finally block " Question  32 Correct Marked out of 1.00 Flag question Question text Which of the following statement(s) is/are TRUE? (i) In a non-correlated(independent) subquery, the subquery is always executed only onc...

Subscribe to Get's Answer by Email