Skip to main content

Count A+b+c+ Subsequences

 1. You are given a string str.

2. You are required to calculate and print the count of subsequences of the nature a+b+c+.

For abbc -> there are 3 subsequences. abc, abc, abbc

For abcabc -> there are 7 subsequences. abc, abc, abbc, aabc, abcc, abc, abc.

Input Format

A string str

Output Format

count of subsequences of the nature a+b+c+


Constraints

0 < str.length <= 10

Sample Input

abcabc

Sample Output

7


Solution:

import java.io.*;
import java.util.*;

public class Main {

    public static void main(String[] args) throws Exception {
        Scanner sc = new Scanner(System.in);
        String str = sc.nextLine();
        int counta = 0, countb = 0, countc = 0;
        for(int i=0;i<str.length();i++){
            char ch = str.charAt(i);
            if(ch == 'a')
                ++counta;
            else if(ch == 'b')
                ++countb;
            else if(ch == 'c')
                ++countc;
        }
        
        long total;
        if(counta == 0 || countb  == 0 || countc == 0)
            total = 0;
        else total = counta + countb + countc;
        System.out.println(total + 1);
    }
}


Comments

Must Read:

Course DH ASE B3 Slot3 Mock 1 Handson | RDBMS

DH ASE B3          Slot3              Mock 1                  Handson: RDBMS

Software Engineering Concepts Software Engineering Fundamentals Post-Quiz

  Software Engineering Concepts       Software Engineering Fundamentals            Post-Quiz

Accenture Mock Quiz | Part 4

  Question  31 Correct Marked out of 1.00 Flag question Question text What will be the output of the following Java code? class Test extends Throwable { } class Base extends Test {} public class Main { public static void main(String args[]) { try { throw new Base(); } catch(Test t) { System.out.println("Test Exception"); } finally { System.out.println("Finally block "); } } } Select one: a.  Complilation error : Bass calss can't extends Test b.  print-"Test Exception" c.  Complilation error: Test Class cant extends Throwable d.  print - "Test Exception" "Finally block "   Feedback The correct answer is: print - "Test Exception" "Finally block " Question  32 Correct Marked out of 1.00 Flag question Question text Which of the following statement(s) is/are TRUE? (i) In a non-correlated(independent) subquery, the subquery is always executed only onc...

Subscribe to Get's Answer by Email