Skip to main content

Target Sum Subsets - Dp

1. You are given a number n, representing the count of elements.

2. You are given n numbers.

3. You are given a number "tar".

4. You are required to calculate and print true or false, if there is a subset the elements of which add 

     up to "tar" or not.

Input Format

A number n

n1

n2

.. n number of elements

A number tar

Output Format

true or false as required


Constraints

1 <= n <= 30

0 <= n1, n2, .. n elements <= 20

0 <= tar <= 50

Sample Input

5

4

2

7

1

3

10

Sample Output

true


Solution:

import java.io.*;
import java.util.*;

public class Main {

    public static void main(String[] args) throws Exception {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        int[] arr = new int[n];
        for(int i=0;i<n;i++)
            arr[i] = sc.nextInt();
        int tar = sc.nextInt();
        
        boolean[][] dp = new boolean[n+1][tar+1];
        for(int j=0;j<=n;j++)
            dp[j][0] = true;
        
        for(int i=1;i<=n;i++){
            for(int j=1;j<=tar;j++){
                dp[i][j] = dp[i-1][j];
                int pos = j-arr[i-1];
                if(pos>=0)
                    dp[i][j] = dp[i][j] || (pos == 0) || dp[i-1][pos];
            }
        }
        
        System.out.println(dp[n][tar]);
    }
}

Comments

Must Read:

Course DH ASE B3 Slot3 Mock 1 Handson | RDBMS

DH ASE B3          Slot3              Mock 1                  Handson: RDBMS

Software Engineering Concepts Software Engineering Fundamentals Post-Quiz

  Software Engineering Concepts       Software Engineering Fundamentals            Post-Quiz

Accenture Mock Quiz | Part 4

  Question  31 Correct Marked out of 1.00 Flag question Question text What will be the output of the following Java code? class Test extends Throwable { } class Base extends Test {} public class Main { public static void main(String args[]) { try { throw new Base(); } catch(Test t) { System.out.println("Test Exception"); } finally { System.out.println("Finally block "); } } } Select one: a.  Complilation error : Bass calss can't extends Test b.  print-"Test Exception" c.  Complilation error: Test Class cant extends Throwable d.  print - "Test Exception" "Finally block "   Feedback The correct answer is: print - "Test Exception" "Finally block " Question  32 Correct Marked out of 1.00 Flag question Question text Which of the following statement(s) is/are TRUE? (i) In a non-correlated(independent) subquery, the subquery is always executed only onc...

Subscribe to Get's Answer by Email